Bibliography

[Cannon et al.] , CannonLWothers. Recommended C style and coding standards. http://sunland.gsfc.nasa.gov/info/cstyle.html.

[Cant et al. 1995] CantSNJefferyDRHenderson-SellersBL (1995, June). “A conceptual model of cognitive complexity of elements of the programming process”. Information and Software Technology 37(7), 351–362.

[Capiluppi and Robles 2007] , CapiluppiARoblesG (Eds.) (2007, May). FLOSS '07: Proceedings of the First International Workshop on Emerging Trends in FLOSS Research and Development. IEEE Computer Society.

[Chidamber and Kemerer 1994] ChidamberSRKemererCF (1994). “A metrics suite for object oriented design”, http://dx.doi.org/10.1109/32.295895. IEEE Transactions on Software Engineering 20(6), 476–493.

[Coleman et al. 1994] ColemanDAshDLowtherBOmanPW (1994). “Using metrics to evaluate software system maintainability”, http://dx.doi.org/10.1109/2.303623. Computer 27(8), 44–49.

[Cusumano and Selby 1995] , CusumanoMASelbyRW (1995). Microsoft Secrets. New York: The Free Press.

[Dickinson 1996] DickinsonK (1996). “Software process framework at Sun”, 10.1145/240819.240830. StandardView 4(3), 161–165.

[Feller 2005] , FellerJ (Ed.) (2005). 5-WOSSE: Proceedings of the Fifth Workshop on Open Source Software Engineering. ACM Press.

[Feller and Fitzgerald 2001] , FellerJFitzgeraldB (2001). Understanding Open Source Software Development. Reading, MA: Addison-Wesley.

[Feller et al. 2005] , FellerJFitzgeraldBHissamSLakhaniK (Eds.) (2005). Perspectives on Free and Open Source Software. Boston: MIT Press.

[Fitzgerald and Feller 2002] FitzgeraldBFellerJ (2002). “A further investigation of open source software: Community, co-ordination, code quality and security issues”, 10.1046/j.1365-2575.2002.00125.x. Information Systems Journal 12(1), 3–5.

[Gill and Kemerer 1991] GillGKKemererCF (1991). “Cyclomatic complexity density and software maintenance productivity”, http://dx.doi.org/10.1109/32.106988. IEEE Transactions on Software Engineering 17(12), 1284–1288.

[Glass 1999] GlassRL (1999, January/February). “Of open source, Linux ... and hype”. IEEE Software 16(1), 126–128.

[Halstead 1977] , HalsteadMH (1977). Elements of Software Science. New York: Elsevier New Holland.

[Harbison and Steele Jr. 1991] , HarbisonSPSteele Jr.GL (1991). C: A Reference Manual Third ed.. Englewood Cliffs, NJ: Prentice Hall.

[Henry and Kafura 1981] HenrySMKafuraD (1981). “Software structure metrics based on information flow”. IEEE Transactions on Software Engineering SE-7(5), 510–518.

[Hoepman and Jacobs 2007] HoepmanJHJacobsB (2007). “Increased security through open source”, http://doi.acm.org/10.1145/1188913.1188921. Communications of the ACM 50(1), 79–83.

[Izurieta and Bieman 2006] IzurietaCBiemanJ (2006). “The evolution of FreeBSD and Linux”. In ISESE '06: Proceedings of the 2006 ACM/IEEE International Symposium on Empirical Software Engineering, pp. 204–211. ACM Press.

[Jrgensen 2001] JrgensenN (2001, October). “Putting it all in the trunk: Incremental software development in the FreeBSD open source project”, 10.1046/j.1365-2575.2001.00113.x. Information Systems Journal 11(4), 321–336.

[Kernighan and Plauger 1978] , KernighanBWPlaugerPJ (1978). The Elements of Programming Style Second ed. New York: McGraw-Hill.

[Kuan 2003] KuanJ (2003, January). “Open source software as lead user's make or buy decision: A study of open and closed source quality”. In Second Conference on The Economics of the Software and Internet Industries.

[Li et al. 2006] LiZLuSMyagmarSZhouY (2006). “CP-miner: Finding copy-paste and related bugs in large-scale software code”, 10.1109/TSE.2006.28. IEEE Transactions on Software Engineering 32(3), 176–192.

[McCabe 1976] McCabeTJ (1976). “A complexity measure”. IEEE Transactions on Software Engineering 2(4), 308–320.

[McConnell 2004] , McConnellSC (2004). Code Complete: A Practical Handbook of Software Construction second ed. Redmond, WA: Microsoft Press.

[Parnas 1972] ParnasDL (1972, December). “On the criteria to be used for decomposing systems into modules”. Communications of the ACM 15(12), 1053–1058.

[Paulson et al. 2004] PaulsonJWSucciGEberleinA (2004, April). “An empirical study of open-source and closed-source software products”. IEEE Transactions on Software Engineering 30(4), 246–256.

[Polze and Probert 2006] PolzeAProbertD (2006). “Teaching operating systems: The Windows case”. In SIGCSE '06: Proceedings of the 37th SIGCSE Technical Symposium on Computer Science Education, pp. 298–302. ACM Press.

[Rigby and German 2006] , RigbyPCGermanDM (2006, January). A preliminary examination of code review processes in open source projects. University of Victoria. http://helium.cs.uvic.ca/thread.html/Rigby2006TechReport.pdf.

[Salus 1994] , SalusPH (1994). A Quarter Century of UNIX. Boston, MA: Addison-Wesley.

[Samoladas et al. 2004] SamoladasIStamelosIAngelisLOikonomouA (2004). “Open source software development should strive for even greater code maintainability”, http://doi.acm.org/10.1145/1022594.1022598. Communications of the ACM 47(10), 83–87.

[Small 1947] , SmallHA (Ed.) (1947). Form and Function: Remarks on Art by Horatio Greenough. Berkeley and Los Angeles: University of California Press.

[Sowe et al. 2007] , SoweSKStamelosIGSamoladasI (Eds.) (2007). Emerging Free and Open Source Software Practices. Hershey, PA: IGI Publishing.

[Spencer and Collyer 1992] SpencerHCollyerG (1992, June). “#ifdef considered harmful or portability experience with C news”. In AdamsR (Ed.), Proceedings of the Summer 1992 USENIX Conference, Berkeley, CA, pp. 185–198. USENIX Association.

[Spinellis 2003] SpinellisD (2003, November). “Global analysis and transformations in preprocessed languages”, doi:10.1109/TSE.2003.1245303. IEEE Transactions on Software Engineering 29(11), 1019–1030.

[Spinellis 2006] , SpinellisD (2006). Code Quality: The Open Source Perspective. Boston, MA: Addison-Wesley.

[Spinellis 2008] SpinellisD (2008, May). “A tale of four kernels”. In SchäferWDwyerMBGruhnV (Eds.), ICSE '08: Proceedings of the 30th International Conference on Software Engineering, New York, pp. 381–390. Association for Computing Machinery.

[Spinellis 2010] SpinellisD (2010, April). “CScout: A refactoring browser for C”, 10.1016/j.scico.2009.09.003. Science of Computer Programming 75(4), 216–231.

[Spinellis and Szyperski 2004] SpinellisDSzyperskiC (2004, January/February). “How is open source affecting software development?”, doi:10.1109/MS.2004.1259204. IEEE Software 21(1), 28–33. Guest Editors' Introduction: Developing with Open Source Software.

[Stallman et al. 2005] , StallmanRothers (2005, December). GNU coding standards. http://www.gnu.org/prep/standardstoc.html.

[Stamelos et al. 2002] StamelosIAngelisLOikonomouABlerisGL (2002). “Code quality analysis in open source software development”, 10.1046/j.1365-2575.2002.00117.x. Information Systems Journal 12(1), 43–60.

[Stol et al. 2009] StolKJBabarMARussoBFitzgeraldB (2009). “The use of empirical methods in open source software research: Facts, trends and future directions”. In FLOSS '09: Proceedings of the 2009 ICSE Workshop on Emerging Trends in Free/Libre/Open Source Software Research and Development, Washington, DC, USA, pp. 19–24. IEEE Computer Society.

[Tanenbaum 1987] , TanenbaumAS (1987). Operating Systems: Design and Implementation. Englewood Cliffs, NJ: Prentice Hall.

[The FreeBSD Project 1995] , The FreeBSD Project (1995, December). Style---Kernel Source File Style Guide. The FreeBSD Project. FreeBSD Kernel Developer's Manual: style(9). Available online http://www.freebsd.org/docs.html (January 2006).

[Torvalds and Diamond 2001] , TorvaldsLDiamondD (2001). Just for Fun: The Story of an Accidental Revolutionary. New York: HarperInformation.

[von Krogh and von Hippel 2006] vKroghGvHippelE (2006, July). “The promise of research on open source software”, 10.1287/mnsc.1060.0560. Management Science 52(7), 975–983.

[Yu et al. 2006] YuLSchachSRChenKHellerGZOffuttJ (2006). “Maintainability of the kernels of open source operating systems: A comparison of Linux with FreeBSD, NetBSD and OpenBSD”, 10.1016/j.jss.2005.08.014. Journal of Systems and Software 79(6), 807–815.

[Yu et al. 2004] YuLSchachSRChenKOffuttJ (2004). “Categorization of common coupling and its application to the maintainability of the Linux kernel”, 10.1109/TSE.2004.58. IEEE Transactions on Software Engineering 30(10), 694–706.